织女星开发板使用的软件必须是Eclipse?

Home 论坛 一般性讨论 织女星开发板使用的软件必须是Eclipse?

  • This topic has 6 个回复, 5 个参与人, and was last updated 5 years 前 by limalelimale.
正在查看 5 帖子:1-5 (共 7 个帖子)
  • 作者
    帖子
  • #1705
    howedestarkhowedestark
    参与者

    织女星开发板可不可以用别的编程软件来写?比如Keil

    #1707
    chao wangwhik
    参与者

    你好,我是刚开始玩织女星开发板。可以使用Keil来开发ARM内核程序的,如片上的ARM Cortex-M4F或ARM Cortex-M0+,官方SDK中有支持RV32M1的器件包,安装之后,就可以用来下载调试了。不过RV32M1默认是从RISC-V内核启动,如果开发ARM内核,还需要切换为ARM核启动,关于如何切换内核,可以参考:

    不过,RV32M1是一颗真正的RISC-V芯片,它还有两颗性能很强的RISC-V内核,可以学习一下它的开发和使用。RISC-V内核的开发需要搭建基于Eclipse和RISC-V GCC编译器的开发环境,可以使用板载的调试器来进行调试和下载。可以参考:

    #1708
    howedestarkhowedestark
    参与者
    • 内核就得用eclipse ide了呗
    #1711
    day_dayday_day
    参与者

    Risc-v内核的eclipse工程我就没有成功弄出来过orz,不知道哪里没配置好,一直出错,看来迟点换上linux平台开发算了

    #1712
    chao wangwhik
    参与者

    使用板载调试器,配合Openocd,单步调试,程序下载,都可以在Eclipse环境下完成。

正在查看 5 帖子:1-5 (共 7 个帖子)
  • 抱歉,回复话题必需登录。